Phone systems down
Incident Report for Payfast
Resolved
This problem has been resolved.
Posted May 22, 2024 - 15:59 SAST
Identified
Our external phone lines are currently down, we are engaging with Upstream Providers on a resolution to the problem.
Posted May 22, 2024 - 11:43 SAST
This incident affected: General (HelpDesk).