Credit Card Payments Degraded success rates
Incident Report for Payfast
Resolved
3dSecure verification has returned to normal, allowing card payments to occur. We are continuing to monitor actively
Posted Feb 03, 2023 - 14:34 SAST
Update
The issue is still ongoing. We are continuing to monitor and liaise with Upstream partners for resolution.
Posted Feb 03, 2023 - 13:25 SAST
Update
Update: The issue is ongoing, We are seeing some successes, but there is an escalated decline rate.
Posted Feb 03, 2023 - 11:27 SAST
Monitoring
We are seeing some successful payments, but many are still failing 3dSecure verification.
Posted Feb 03, 2023 - 09:14 SAST
Investigating
3dSecure verification is down affecting most credit card payments across all banks. We are engaging with our Upstream Partners to resolve the situation.
This started at 6:30am.
Posted Feb 03, 2023 - 06:30 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).