Capitec Pay degraded

Incident Report for Payfast

Resolved

This problem affecting Capitec Pay transactions has been resolved on both Aggregation InstantEFT and Gateway SiD.
Posted Aug 01, 2025 - 12:58 SAST

Identified

A problem with Capitec Pay transactions on both Aggregation Instant EFT and Gateway SiD has been identified. We are in contact with External partners on the matter.
Posted Aug 01, 2025 - 11:46 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay) and Payfast Gateway: SiD (Capitec Pay).