Capitec Pay degradation

Incident Report for Payfast

Resolved

This problem has been resolved with Capitec Pay transactions processing normally again.
Posted Oct 30, 2025 - 13:30 SAST

Identified

A problem with Capitec Pay transactions has been identified on the Aggregation Platform, we are in contact with External Partners on the matter.
Posted Oct 30, 2025 - 12:40 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay).