Immediate Payouts on Aggregation

Incident Report for Payfast

Resolved

This problem has been resolved for Immediate Payouts. They are available again.
Posted Jun 26, 2025 - 16:45 SAST

Identified

We have temporarily disabled Immediate Payouts.
Teams are engaging with External partners on the matter.
Posted Jun 26, 2025 - 08:38 SAST
This incident affected: General (Aggregation Payouts).