Absa on SiD
Incident Report for Payfast
Resolved
This problem for Absa payments on Gateway SiD has been resolved.
Posted Nov 13, 2024 - 13:59 SAST
Investigating
Absa transactions via Gateway SiD are currently encountering an issue completing, this is being worked on.
Kindly opt to pay using a different payment method where possible.
Posted Nov 13, 2024 - 09:07 SAST
This incident affected: Payfast Gateway: SiD (Absa).