Merchant Dashboard
Incident Report for Payfast
Resolved
This intermittent issue has been resolved.
Posted Sep 30, 2024 - 09:52 SAST
Investigating
Some users are experiencing performance issues on the Merchant Dashboard for Aggregation, this is being investigated.
Posted Sep 30, 2024 - 09:06 SAST
This incident affected: General (Aggregation Merchant Dashboard).