Degraded Credit Card payments
Incident Report for Payfast
Resolved
The issue has been resolved, card processing has returned to normal.
Posted Apr 04, 2023 - 12:33 SAST
Investigating
An issue with Credit Card Payments has been identified and escalated with an Upstream Provider.
Posted Apr 04, 2023 - 10:47 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments, Recurring payments).