SSL related disruption on Aggregation

Incident Report for Payfast

Resolved

This SSL related problem has been resolved on the Aggregation platform. Processing and ITN's are functioning normally again.
Posted Nov 07, 2025 - 08:47 SAST

Identified

Some merchants are experiencing problems related to SSL's on the Aggregtion Platform.
For those impacted, the problem could arise in either payment processing or upon ITN validation, it will differ from merchant to merchant.

We are engaging with the issue.
Posted Nov 07, 2025 - 08:00 SAST
This incident affected: General (Aggregation Processing (non Payment method specific), Aggregation Callbacks/ITN).