Capitec on 3D Secure

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 12:31 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2025 - 12:29 SAST

Identified

Capitec card-holders are currently experiencing problems with the 3D Secure leg of card payments.
We are in contact with External Partners on the matter.
Posted Aug 04, 2025 - 11:30 SAST
This incident affected: Payfast Gateway: Cards (3D Secure, Capitec involved transactions) and Payfast Aggregation: Cards (3D Secure, Capitec involved transactions).