Capitec Pay problems
Incident Report for Payfast
Resolved
This problem has been resolved. Capitec Pay transactions are functioning normally again.
Posted May 15, 2024 - 15:58 SAST
Investigating
A problem with Capitec Pay transactions has been identified and is being investigated.
Posted May 15, 2024 - 14:15 SAST
This incident affected: Instant EFT (Capitec).