Capitec Pay
Incident Report for Payfast
Resolved
This problem has been resolved. Capitec Pay is functioning normally again.
Posted Jun 28, 2024 - 12:23 SAST
Identified
A problem with Capitec Pay has been identified and escalated with Upstream Partners.
Posted Jun 28, 2024 - 11:15 SAST
This incident affected: InstantEFT (Capitec).