Capitec based Payments
Incident Report for Payfast
Resolved
This problem has resolved. Capitec payments on both credit card and Instant EFT are working again.
Posted Mar 22, 2024 - 18:55 SAST
Identified
Please note that Capitec payments on both credit card and Instant EFT are currently failing.
This matter has been escalated.
Posted Mar 22, 2024 - 18:15 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments, Recurring payments) and Instant EFT (Capitec).