Samsung Pay on Aggregation

Incident Report for Payfast

Resolved

This problem has been resolved for Samsung Pay transactions on Aggregation.
Posted Jul 09, 2025 - 09:56 SAST

Identified

A problem with Samsung Pay transactions on the Aggregation platform has been identified. Teams are currently looking into the matter.
Posted Jul 09, 2025 - 08:47 SAST
This incident affected: Payfast Aggregation: Alternative Payment Methods (Samsung Pay).