Immediate payouts unavailable

Incident Report for Payfast

Resolved

This problem has been resolved. Immediate payouts on Aggregation are available again.
Posted Jul 16, 2025 - 10:09 SAST

Identified

Immediate Payout requests on Aggregation are currently disabled.
Posted Jul 16, 2025 - 08:48 SAST
This incident affected: General (Aggregation Immediate Payouts).