African Bank on Instant EFT
Incident Report for Payfast
Resolved
African Bank is enabled again.
Posted Mar 12, 2024 - 19:18 SAST
Monitoring
Please note that African Bank payments on Instant EFT are currently undergoing maintenance and will be temporarily unavailable.
Posted Feb 27, 2024 - 20:59 SAST
This incident affected: Instant EFT (African Bank).