RCS payments

Incident Report for Payfast

Resolved

This problem has been resolved for RCS payments
Posted Jun 25, 2025 - 15:31 SAST

Identified

A problem with RCS Payments has been identified, affecting both Aggregation and Gateway systems and is being looked into currently.
Posted Jun 25, 2025 - 12:14 SAST
This incident affected: Payfast Gateway: Alternative Payment Methods (Store Cards (RCS)) and Payfast Aggregation: Alternative Payment Methods (Store Cards (RCS)).