Completed
The scheduled maintenance has been completed.
Posted Nov 19, 2024 - 02:45 SAST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 19, 2024 - 02:00 SAST
Scheduled
The Payfast Gateway system will be undergoing maintenance on November 19th 2024 from 2am for 45 minutes.
During this period, the Gateway system will be unavailable.
Posted Nov 18, 2024 - 18:57 SAST
This scheduled maintenance affected: Payfast Gateway: Cards (Absa involved transactions, Bidvest involved transactions, Capitec involved transactions, Discovery involved transactions, FNB involved transactions, Investec involved transactions, Nedbank involved transactions, Standard Bank involved transactions, American Express involved transactions), Payfast Gateway: SiD (Absa, African Bank, Bidvest Bank, Capitec Pay, Discovery Bank, FNB, Investec Bank, Nedbank, Standard Bank, Tyme Bank), and Payfast Gateway: Alternative Payment Methods (Apple Pay, Mobicred, Momopay, PayPal, Samsung Pay, Scan to Pay, Store Cards (RCS), Visa Checkout, Zapper).