Capitec Pay degraded

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 16:13 SAST

Identified

A problem affecting Capitec Pay has been identified and is being investigated by Upstream partners. This is affecting card payments on Gateway and Aggregation as well as Instant EFT and Gateway SiD payments.
Posted Apr 04, 2025 - 12:00 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay), Payfast Gateway: Cards (Capitec involved transactions), Payfast Gateway: SiD (Capitec Pay), and Payfast Aggregation: Cards (Capitec involved transactions).