Support chat unavailable.
Incident Report for Payfast
Resolved
Support chat continues to have problems related to a general internet issue across Africa.
If needed this status page may go up again on Monday if the problem persists then.
Posted Mar 15, 2024 - 16:51 SAST
Identified
A problem with Support Chat has been identified due to the general Internet issues occurring since yesterday. Calls are fully operational.
Posted Mar 15, 2024 - 11:12 SAST
This incident affected: General (HelpDesk).