Phishing email

Incident Report for Payfast

Resolved

This post is being taken down.
For more information on phishing, please visit:
https://support.payfast.help/portal/en/kb/articles/suspicious-emails-phishing-scams
Posted Mar 31, 2026 - 06:45 SAST

Identified

We’re aware of a fraudulent email currently being sent to consumers, requesting confirmation of card details and urging recipients to click a link.

This email is not from Payfast. It is a phishing scam and should be deleted immediately.
This matter has been escalated to our internal security teams and reported to the relevant authorities.

To learn more about how to spot suspicious emails and keep your account safe, read this article:
https://support.payfast.help/portal/en/kb/articles/suspicious-emails-phishing-scams
Posted Mar 27, 2026 - 09:58 SAST
This incident affected: General (General Information).