Capitec Pay

Incident Report for Payfast

Resolved

This problem for Capitec Pay transactions has been resolved.
Posted Aug 20, 2025 - 18:52 SAST

Identified

A problem with Capitec Pay transactions has been identified, affecting both Aggregation Instant EFT and Gateway SiD.
We are engaging with Capitec on the matter.
Posted Aug 20, 2025 - 16:33 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay) and Payfast Gateway: SiD (Capitec Pay).