Capitec Pay degraded

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 12:31 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2025 - 12:30 SAST

Identified

A problem with transactions for Capitec Pay has been identified affecting both Aggregation Instant EFT and Gateway SiD.
We are in contact with External Partners on the matter.
Posted Aug 04, 2025 - 11:27 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay) and Payfast Gateway: SiD (Capitec Pay).