Sandbox Maintenace
Incident Report for Payfast
Resolved
Sandbox is back up and working
Posted Apr 08, 2024 - 12:24 SAST
Identified
Please note that our Test environment is currently undergoing maintenance.
Posted Apr 05, 2024 - 16:30 SAST
This incident affected: Integrations (Sandbox).