Payouts degraded
Incident Report for Payfast
Resolved
This problem has been resolved.
Posted Sep 21, 2024 - 11:39 SAST
Investigating
Some users are having problems initiating Payouts on the Aggregation system, this is being investigated currently.
Posted Sep 20, 2024 - 17:02 SAST
This incident affected: General (Aggregation Payouts).