Merchant Logins for Aggregation
Incident Report for Payfast
Resolved
This problem has been resolved.
Posted Sep 19, 2024 - 20:33 SAST
Investigating
An intermittent problem for some Users trying to log into the Merchant Dashboard on Aggregation has been identified and is being investigated currently.
Posted Sep 19, 2024 - 17:55 SAST
This incident affected: General (Aggregation Merchant Dashboard).