Samsung Pay/Mobicred Payments

Incident Report for Payfast

Resolved

This problem has been resolved. Both Mobicred and Samsun Pay transactions are operational.
Posted Sep 30, 2024 - 19:22 SAST

Update

Mobicred payments are working again. Samsung Pay is still being attended to.
Posted Sep 30, 2024 - 15:19 SAST

Identified

A problem preventing payments on both Samsung Pay and Mobicred transactions for Aggregation has been identified and escalated with External Partners.
Posted Sep 30, 2024 - 13:46 SAST
This incident affected: Payfast Aggregation: Alternative Payment Methods (Mobicred, Samsung Pay).