Degraded Instant EFT Performance
Incident Report for Payfast
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 17:14 SAST
Update
We are continuing to work on a fix for this issue.
Posted Apr 02, 2024 - 15:02 SAST
Identified
An issue with Instant EFT Processing has been identified. We are investigating the matter and will update accordingly.
Posted Apr 02, 2024 - 13:27 SAST
This incident affected: Instant EFT (FNB, Standard Bank, Absa, Nedbank, Tyme Bank, Investec, African Bank, Bidvest Bank).