ITN's delayed
Incident Report for Payfast
Resolved
This problem has been resolved.
Posted Jul 02, 2024 - 07:19 SAST
Identified
A problem with ITN's has been identified and is being investigated.
Posted Jul 01, 2024 - 10:30 SAST
This incident affected: General (Callbacks/ITN).