Mobicred issues

Incident Report for Payfast

Resolved

This problem has been resolved. Mobicred transactions are completing again on both the Aggregation and Gateway platforms.
Posted Jun 04, 2026 - 11:38 SAST

Identified

Mobicred is currently experiencing processing problems on both the Aggregation and Gateway Platforms.
We are in contact with External Partners on the matter.
Posted Jun 04, 2026 - 09:16 SAST
This incident affected: Payfast Aggregation: Alternative Payment Methods (Mobicred) and Payfast Gateway: Alternative Payment Methods (Mobicred).