FNB card payments

Incident Report for Payfast

Resolved

This problem for FNB card payments has been resovled.
Posted Aug 19, 2026 - 11:45 SAST

Identified

A problem with card payments for FNB buyers has been identified on both the Aggregation and Gateway Platforms.

We are in contact with External Providers and the Bank to resolve the matter.
Posted Aug 19, 2026 - 11:09 SAST
This incident affected: Payfast Gateway: Cards (FNB involved transactions) and Payfast Aggregation: Cards (FNB involved transactions).