Problems with Credit Card payments
Incident Report for Payfast
Resolved
This problem has been resolved. Card payments have returned to normal.
Posted Feb 02, 2024 - 08:01 SAST
Identified
A problem with Card transactions completing has been identified and escalated with an Upstream Partner.
Posted Feb 02, 2024 - 07:28 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments, Recurring payments).