Aggregation Payouts

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 11:24 SAST

Identified

Some merchants are experiencing problems processing a payout on Aggregation, this is being worked on currently.
Posted Feb 18, 2025 - 13:38 SAST
This incident affected: General (Aggregation Payouts).