Aggregation Emails

Incident Report for Payfast

Resolved

This problem affecting emails on Aggregation has been resolved.
Posted Sep 01, 2025 - 15:09 SAST

Identified

We have identified an issue with Aggregation mails affecting most emails on the Aggregation system. Teams are addressing the matter currently.
Please note that this is affecting emails only.
Posted Sep 01, 2025 - 09:41 SAST
This incident affected: General (Aggregation Emails).