EFT payments for FnB

Incident Report for Payfast

Resolved

This problem has been resolved for FnB EFT payments.
Posted Dec 02, 2025 - 06:21 SAST

Identified

Payments using FnB for both Aggregation Instant EFT and Gateway SiD are currently degraded. The payment method has been switched off for the moment.
Posted Dec 01, 2025 - 06:26 SAST
This incident affected: Payfast Aggregation: Instant EFT (FNB) and Payfast Gateway: SiD (FNB).