Standard Bank on Instant EFT

Incident Report for Payfast

Resolved

This incident is being updated.
Posted Jul 11, 2023 - 10:45 SAST

Update

Standard Bank has been re-enabled on Instant EFT, buyers may encounter processing issues for the moment.
Posted May 19, 2023 - 13:26 SAST

Update

Standard Bank EFT payments are currently unavailable. Please use an alternative payment method.
Posted May 09, 2023 - 12:54 SAST

Update

We are continuing to work on a fix for this issue.
Posted Apr 06, 2023 - 16:56 SAST

Identified

An issue with Standard Bank payments has been escalated. We will post updates when available.
Posted Feb 22, 2023 - 11:55 SAST
This incident affected: Payfast Aggregation: Instant EFT (Standard Bank).