Capitec on Instant EFT

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Nov 10, 2023 - 12:48 SAST

Update

We continue to monitor for problems
Posted Nov 10, 2023 - 12:47 SAST

Monitoring

Please be advised that while Instant EFT is available for CapitecPay customers, some customers may encounter issues with the new service.
In such cases, kindly opt to pay using an alternative payment method for the moment
Posted Oct 04, 2023 - 10:50 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay).