Capitec on Instant EFT

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Jun 11, 2024 - 07:30 SAST

Update

We are continuing to monitor for any further issues.
Posted Jun 11, 2024 - 07:23 SAST

Monitoring

Please be advised that while Instant EFT is available for CapitecPay customers. Kindly opt to pay using an alternative payment method for the moment
Posted Jun 11, 2024 - 06:30 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay).