3D Secure degraded

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 12:39 SAST

Update

This problem has been resolved for Nedbank card-holders on 3D Secure.
Posted Apr 25, 2025 - 12:38 SAST

Identified

A problem with Nedbank card-holders completing the 3D secure leg of card transactions has been identified.
This is impacting both Aggregation and Gateway card payments currently. We are in contact with external partners on the matter.
Posted Apr 25, 2025 - 10:24 SAST
This incident affected: Payfast Gateway: Cards (3D Secure, Nedbank involved transactions) and Payfast Aggregation: Cards (3D Secure, Nedbank involved transactions).