Phone calls to the PayFast helpdesk currently intermittent or non-operational.
Incident Report for Payfast
Resolved
Phone call service has been restored in our customer service department.
Posted Jul 21, 2021 - 10:33 SAST
Identified
An issue has been identified that is preventing our customer service staff to accept phone calls. Our technical team is working on a fix. PayFast transactional systems are not affected and payments are proceeding.
Posted Jul 21, 2021 - 10:02 SAST
This incident affected: General (HelpDesk).