Telephonic calls

Incident Report for Payfast

Resolved

This problem has been resolved.
Posted Feb 02, 2026 - 23:58 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 02, 2026 - 16:24 SAST

Identified

Calls to our Helpdesk are currently offline, we are in contact with External Partners on this matter.
Please email support@payfast.help for the moment, or the chatbot that can be found on the main landing page https://www.payfast.io
Posted Feb 02, 2026 - 16:13 SAST
This incident affected: General (Help Desk).