Investec EFT Payments
Incident Report for Payfast
Resolved
This problem affecting Investec EFT payments has been resolved.
Posted Dec 09, 2024 - 15:59 SAST
Identified
Please note that payments from Investec Bank on both Aggregation Instant EFT and Gateway SiD are currently degraded.
Posted Dec 05, 2024 - 10:20 SAST
This incident affected: Payfast Aggregation: Instant EFT (Investec) and Payfast Gateway: SiD (Investec Bank).