Mobicred transactions

Incident Report for Payfast

Resolved

This problem has been resolved for Mobicred payments.
Posted Jul 01, 2025 - 05:31 SAST

Identified

Mobicred payments are currently failing, this is affecting payments on both Aggregation and Gateway.
We are in contact with them on the matter.
Posted Jun 30, 2025 - 10:04 SAST
This incident affected: Payfast Aggregation: Alternative Payment Methods (Mobicred) and Payfast Gateway: Alternative Payment Methods (Mobicred).