Capitec Pay EFT Payments
Incident Report for Payfast
Resolved
This incident has been resolved.
Posted Aug 23, 2024 - 20:58 SAST
Update
We are continuing to monitor for any further issues.
Posted Aug 23, 2024 - 19:06 SAST
Monitoring
Please note that Capitec Pay on Instant EFT & SiD is currently unavailable. Kindly opt to pay using an alternative payment method for the moment.
Posted Aug 23, 2024 - 17:50 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay) and Payfast Gateway: SiD (Capitec Pay).