Telephonic calls

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 13:08 SAST

Update

This problem has been resolved, calls to the Helpdesk are fully operational again
Posted Feb 28, 2025 - 13:08 SAST

Update

This problem has been resolved, we continue to monitor for stability
Posted Feb 28, 2025 - 13:03 SAST

Identified

Calls to our Helpdesk are currently offline, we are in contact with External Partners on this matter.
Please email support@payfast.help for the moment, or the chatbot that can be found on the main landing page https://www.payfast.io
Posted Feb 28, 2025 - 12:45 SAST
This incident affected: General (Help Desk).