ITN's delayed.
Incident Report for Payfast
Resolved
This problem has been resolved.
Posted Jul 02, 2024 - 16:51 SAST
Monitoring
ITN's are being delivered timeously now, we will continue to closely monitor this throughout the day.
Posted Jul 02, 2024 - 13:54 SAST
Identified
A problem with ITN's has been identified and is being investigated.
Posted Jul 02, 2024 - 10:36 SAST
This incident affected: General (Aggregation Callbacks/ITN).