Please be advised that while Instant EFT is available for CapitecPay customers, some customers may encounter issues with the new service. In such cases, kindly opt to pay using an alternative payment method for the moment.
Posted Apr 21, 2023 - 15:57 SAST
Update
Attention Capitec Customers
Please be advised that instant EFT is temporarily unavailable as a payment method. Kindly opt to pay using an alternative payment method.
Posted Apr 06, 2023 - 17:17 SAST
Update
Attention Capitec Customers
Please be advised that instant EFT is temporarily unavailable as a payment method. Kindly opt to pay using an alternative payment method.
Posted Apr 04, 2023 - 16:06 SAST
Investigating
Attention Capitec Customers
An issue with EFT Payments via Capitec has been identified and escalated.
Posted Apr 04, 2023 - 07:48 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay).