PayFast Telephone Issues
Incident Report for Payfast
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 15:26 SAST
Investigating
Kindly note that we are currently experiencing issues with our telephone lines. This has been escalated to our upstream partners for urgent resolution. In the interim please reach out to us via email or live chat via our website - https://payfast.io/
Posted Apr 05, 2024 - 15:10 SAST
This incident affected: General (HelpDesk).