Aggregation Card Updates

Incident Report for Payfast

Resolved

This problem has been resolved. Card updates on Aggregation are working again.
Posted Sep 02, 2025 - 09:49 SAST

Identified

We have identified an issue with Card updates for Recurring transactions. Teams are currently addressing the situation with External Partners.
Posted Sep 02, 2025 - 08:24 SAST
This incident affected: Payfast Aggregation: Cards (Aggregation Card Updates).