Nedbank on Instant EFT
Incident Report for Payfast
Resolved
Nedbank has been re-enabled on Instant EFT.
Posted Apr 10, 2024 - 09:45 SAST
Update
We are disabling the bank due to degraded approvals, while we continue to investigate.
Posted Apr 03, 2024 - 19:43 SAST
Investigating
An issue with Nedbank on Instant EFT has been identified. We are investigating the matter and will update accordingly.
Posted Apr 03, 2024 - 10:41 SAST
This incident affected: Instant EFT (Nedbank).